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Introduction

Airports with Condor 3 bring several fundamental new features:
 Longitudinal and cross-sectional profile of the airfield preserved, instead of a flat terrain
 3D grass.

These new features only apply to the G file of airports that contain all the surfaces of an airport. The O 
file of each airport is built identically to Condor 2, and it contains all the superstructures of the airport.

For this it is necessary to use a finer support grid in 22.5 m and with precision lower than the meter in 
order to avoid bumps and edge effects with the visualization of the 3D grass. This grid in TR3F (F for 
Float) allows to create dedicated sub-textures.

All illustrations are made with the soft: Landscape Editor version 3.00, Object editor, from the 
Landscape Toolkit 2, Blender 4.2 LTS and The Gimp or Photoshop Wings 3D can also be used instead of 
Blender. LMB, RMB, MMB, etc., are used for clicks with the Left, Right, Middle Mouse Buttons.

Condor 3 Sceneries are all linked to a UTM projection and divided into square Terragen tiles of 23040 m.
This value is the result of 769 columns/rows of altimetry data spaced by 768 x 30 m wide intervals from 
SRTM data (768 x 30 = 23040 m). Terragen tiles are divided into 4 x 4 patches.

The patches have a fixed dimension of 5760 m on each side (192 x 30 m). The dimension of the texture 
in pixels of each patch is dependent on the quality of the texture applied, i.e. 1024, 2048, 4096, 8182, 
etc., pixels. Textures of patches including airports can have a larger dimension than the standard 
patches.

The standard for a Condor 3 patch is 2048 pixels, i.e. exactly 2.8125 m/pixel.

Airport smoothing
Most terrain on airfields is bumpy to begin with.

We must smooth this while preserving the general slope and the
particular curvatures of the runway and its surroundings. 

Also pay attention to the areas of the airfield that have parks and
buildings.

Also remember that today, the glider storage areas during
multiplayer flights concern (Figure 1):
An area of 16 gliders in line, i.e. a rectangle of 30 x 200 m, from the
start located 170 m from the end of the runway.
Adjoining this area is an area of 80 x 35 m where at least 3 rows of 5
gliders could be stored.
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It may be necessary to flatten these areas as well.
Open Landscape Editor (3.00) (Figure 2) Select the
scenery you need. LMB on the drop-down arrow,
then LMB on the scene name. Select the Airport
checkbox. Create or search for the airport you want
to process. Then zoom in so that it fills the window.
After selecting the "hand" tool, LMB in the main
window to zoom in, RMB to zoom out, LMB_M to
move.

Select the arrow tool  (Figure 3):

RMB in the main LE panel, in order to convert the corresponding patch (green arrow) of the airport.

A pop menu is displayed

Select "Export TR3 to 22.5m OBJ" . The 22.5m terrain file of the patch will be created in the folder:

Working/Heightmaps/22.5m of the scenery with the notation hxxxyyy.obj or hxxyy.obj depending on 
the chosen patches numbering.

Open Blender4.2 (Figure 4) import the
"obj" file that was just created (File >
Import > Wavefront) from the 
Working/Heightmaps/22.5m folder,

using the following parameters so that the
top view is correctly displayed in the
3D Viewport:

Forward Axis: Y, 

     Up Axis: Z
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Here is what it looks like in the 3D Viewport (Figure 5), as soon as the Clip End is set at 100000 m. 

Access to the clip End by key N > View tab.

UV map the texture onto the terrain
 Switch to Top Orthographic (orthogonal top view), 7 key NP, and check that this view remains in

this position throughout the operation.

 LMB on the UV Editing tab. In the right panel, 3D Viewport, which has automatically switched to
Edit Mode, zoom out with the mouse wheel to display the patch. It appears black and often 
truncated. The canvas is a tight grid (Figure 6). Again, set the Clip End to 100000 m. 

 In the left panel, UV Editor, LMB on New Image. Set the
image definition according to the size of the airport patch in
the panel Create a New image (Figure 7). The standard value
is 2048 x 2048 pixels, but patches containing airports can be
wide size.
LMB on New Image. A black image is created in the panel.
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 Return to the 3D View panel. Select the entire tile (A Key). 
In the menu bar (Figure 8):
UV > Project from View
(Bounds). 
The black image in UV
Editor becomes orange
and by zooming the 22.5 m
canvas is selected and
correctly mapped to the
black image up to the 
bounds of the image.

 LMB on the Shading tab. In the Shading
Editor panel (at the bottom) LMB on 
New. The Principled BSDF and Material
Output nodes are automatically created
and linked.

 In the menu bar (Figure 9): Add > Texture > LMB on Image Texture.
An Image Texture node is displayed. Link Color of Image texture with Base Color of Principled 
BSDF using an LMB_M between these two yellow points (Figure 10). 
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 In Image texture LMB on Open. Select the patch texture corresponding to the location of the 
airport in the scenery, located in the Textures folder. It has the same number as the patch 
transformed into 22.5 m with the prefix t: txxyy.dds.

 LMB on the Layout tab  then on the Material Preview button . Check that you are still in op

Orthographic .The texture of the patch is then perfectly mapped on the patch grid in 22.5 m.
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Airport Area Smoothing
Use Blender to flatten the areas you need. Smooth vertices function is quite effective (Figure 12).
In Edit Mode , still in Top Orthographic , move the 3D Viewport view towards the airport 

(MAJ_MMB, see the Status bar).and zoom in

You will have to select an area at least 2x the width of the runway for this to work well and more if the 
airport zone has large grass areas where a landing is reliable. Use the lasso  to make the selection and 

modify the selection until you get a suitable selection area .

Launch the smoothing operation with an LMB via the Vertex > Smooth Vertice  menu. At the bottom 

right a dialog box must be open and set before any other action. Indeed, only altitudes should be 
modified by the Smooth vertices tool. Z Axis only should be checked, especially if the airport is near the 
edge of the patch or concerns several patches (Figure 13).
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Export the file to Wavefront (.obj) from Blender using the following settings (Figure 14), and store it in:
Working/Heightmaps/22.5m/Modified. 

Forward Axis: Y

          Up Axis: Z

Triangulated Mesh: Notched

Airport Patch Name: hxxyy.obj

Then LMB on Export Wavefront OBJ

Back in Landscape Editor, RMB on the airport in the main window, still with the arrow tool selected

Select "Export modified OBJ to TR3f".

If the operation is successful, an Info panel is displayed. 

In Windows Explorer, copy the TR3f file from (Figure 15):

C:\Condor3\Landscapes\Scene_Name\Working\HeightMaps\22.5m\Modified
To:
C:\Condor3\Landscapes\Scene_Name\HeightMaps\22.5m
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Runway Alignment
In Blender, add a rectangular plane perpendicular to the Z axis, close to the dimensions of the runway. 
For example, 880 for Y and 40 m for X in order to generally remain in the orientation of the airports 
defined in Condor. Move and modify the plane so that it adapts perfectly to the runway. Use the Local 
coordinates of the plane if necessary. It can later be used as a support for the hard runway (Asphalt), or 
signs on the grass (Grasspaint) or signs on the runway (Asphaltpaint) etc.

Once the runway is perfectly aligned, select the rectangular plane. Bring the Scale back to 1 by Object > 
Apply > Scale.
(Figure 17)
Still with the plane selected , just read the information of Item in the Transform table which 

corresponds to the characteristics of the geometric center of the plane, the yellow point .

Position relative to the center of the Patch :

X = -847.35 m
Y = -2360.4 m

Rotation around the vertical Z axis relative to the horizontal Y axis:
Z = -48.781 °

Here we have a little difficulty because Blender uses the trigonometric direction (counterclockwise) 
while Condor uses the geographic direction (clockwise). We must therefore use +48.78 °.

Note these 3 values which will be useful later in this chapter.
Save the Blender file with an appropriate name (e.g.: Project_Name_aero).
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Back in Landscape Editor (Figure 17) 
Hand tools selected, Airport box checked, Zoom on
the airport to be processed and LMB on the name of
the Airport in the corresponding list. The airport is
highlighted . RMB on the highlighted airport. A 

pop-up menu is displayed, LMB on Properties.
The floating Airport properties panel is then

displayed with the values that had been registered 
when creating the Airport. At the bottom in
Landscape Editor the values of Patch X and Patch Y
are displayed . These are those of the patch where

the center of the airport is located. They correspond
to the same values as those of the patch that was
flattened previously.

To definitively fix the positioning of the airport, you
must copy the X and Y values of the central location into the X and Y
fields of the airport properties in Landscape Editor. Copy the values 
of Patch X and PatchY into PATCHX and PATCHY corresponding to
the center of the airport (Figure 18).

This allows to calculate the airport coordinates in the UTM
coordinates of the scene and then to calculate the coordinates of
the Latitudes and Longitudes in the WGS84 projection.

Then press the <----- button .
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This will set the latitude and longitude of the airport , but more

importantly, it will adjust the X and Y fields to the optimal values
for runway placement. You now need to use these revised X and Y
values back into Blender for the runway center .

Note the new values of:
Xr = -847.375 m
and
Yr = -2360.32 m 
you will need them later.

Copy the calculated direction of the airport runway 48.78 ° into
the Direction box .

LMB on OK of Airport Properties to save the changes and close
the panel.

Rebuild the Terrain safety file

File > Export Terrain hash (THA) 

Save the scenery:

File > Save landscape
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Making the airport surfaces

Preparing the terrain

With non-flat runways, the surface objects creations requires more work and must be done quite 
precisely.

Each surface object in the airport G-file must have a reference altitude set to an altitude of 0 m, and it 
must be generated by extracting a section of the terrain from the patch with the correct shape and 
contours.

We must first make a copy of the patch with the reference plane in Blender, then move, rotate and 
adjust the height so that the runway is precisely aligned in X and the center of the runway on the patch 
is at altitude 0.

(Figure 21) Switch to Object Mode and Top Orthographic , select the Patch , the values displayed 

in Transform for the Patch are X = 0, Y =0 .

Figure 21

Using the negative Xr and Yr values ,we saved

earlier, move the terrain patch so that the 3D Cursor
is located on the Airport Center. 

Enter the negative Xr and Yr values in the X and Y
location boxes of the Transform panel.
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The Geometric Center of the patch  and the plane representing the runway have not moved.

Set the Geometric Center of the patch to the 3D Cursor by Object > Set Origin > Origin to 3D Cursor.
You will then see that the X, Y values in the Transform panel are set to zero.

Figure 23

Select the plane representing the runway (Figure 23). The Transform panel displays the initially 
calculated X, Y coordinates and not the corrected Xr and Yr values. This is normal, because in Blender 
the center of the plane representing the track has not been corrected.
To move the plane representing the runway to the center of the world , the 3D Cursor, simply 

replace these values with X=0, Y = 0 in the Transform panel.

Rotation around Z:

In Condor 3, the runway axis is located on the X axis. So you have to rotate the patch and the plane of 
the complement to - 90° of the track orientation, or: -(90 – 48.781) = -41.219°. Also note this value.

As the patch and the plane representing the runway both have their geometric centers on the Center of 
the World, it is easy to perform this rotation in one go.

In Object Mode, select all the objects with the A key and do the keyboard command: RZ n.nnn.
That is RZ -41.219. Here is the result of the Z rotation (figure 24) in Transform if you select the plane 
(Rot. Z = -90°) or the Patch (Rot. Z= -41.219°). The runway is then perfectly aligned on the X axis.
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Now we need to measure the precise height of the track center.

In Blender, in Edit mode and Top Orthographic, zoom in so that the isosceles right triangle of the patch 
containing the 3D Cursor is contained in the 3D Viewport. This triangle is flat, but its 3 vertices are at 
different altitudes.

To know the exact altitude of the track center, we will make a
provisional assembly of edges and vertices.

Select the edge which is close to the Center of the World to minimize
errors and divide it in two:
Keyboard key 2 > LMB on edge > Edge menu > Subdivide > Number of
cuts 1

A median vertex is created.

Connect this median vertex to the opposite vertex of the triangle
(figure 25):
Keyboard key 1 > Select the 2 vertices > J to join

Select the median vertex and slide it along the edge of the triangle so
that the created edge intersects the Center of the World (figure 26). 
Keyboard key 1 > Vertex Menu > Slide Vertex

Repeat the division operation with the created edge. Select the vertex
and drag it along the edge so that it occupies the Center of the World
(figure 27).

With this vertex still selected , read the altitude Z in Transform ,

and check that X and Y are close to the zero value, 0. Otherwise,
adjust the position of this vertex more precisely.

Z = 1330 m

Note the value. Delete the edges and additional vertices that were used to perform the measurement. 
Use Dissolve for the vertices and edges.

Select the patch and move it along the Z axis by the
negative value of the altitude read (- 1330 m),
directly in the Transform panel.
After bringing the Geometric Center of the patch back
to the World Origin, the centered and oriented patch
must have the coordinates, X = 0, Y = 0 and Z = 0, in
the Transform panel.

Save the Blender file that will be used to make the
cuts in the patch.
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Making the surface objects

Now that we have the terrain surface prepared, making the surfaces is relatively simple.
We just need to create cutter objects in the horizontal plane X, Y for each type of surface. Then using it 
on a copy of the patch, cut the required surface.

Or if you prefer, starting from the airport drawing described by as many flat surfaces as necessary, we 
create the bumpy surfaces from the patch that will be used in the airport G file.

In Blender 4.2, the Knife Project function has become easy to use, to perform this cutting operation.

It works like this:

• Place this cutting surface above the patch, checking that the patch does not interfere with the 
cutting surface.

• Switch to Object Mode and Top Orthographic.
• Select the patch by an LMB.
• Switch to Edit Mode, select the cutting surface in Outliner by CTRL_LMB.
• Perform the cutting: Mesh > LMB on Knife Project.
• Separate the two meshes: Mesh > Separate > Selection.
• Rename the new mesh in Outliner according to the type of cutting surface made. For grass, 

name it Grass3D.

Surfaces

Asphalt
Runways and taxiways, and optionally parking, paths and building bases.

AsphaltPaint
White paint markings on Asphalt.

AsphaltPaintYellow
Yellow paint markings on taxiways. Uses the same white texture as AsphaltPaint, but with material RGB 
settings 0.6, 0.6, 0.0.

GrassPaint
Paint marks on grass.

Grass and Grass3D
Short runway with real grass with GrassPaint and Asphalt cut after all other objects have been made.

Gravel
This is a new texture for gravel paths, etc.

It may be a good idea to have Grass encompass all Asphalt surfaces, and Gravel surfaces, and initially 
take the shape of the overall outline of the airport.
Indeed, the different surfaces have a nested appearance.
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Grass is cut first. Then inside Grass we cut Asphalt, Gravel and GrassPaint.
Grass is then in its final form and becomes Grass3D.
AsphaltPaint and AsphaltPaintYellow should NOT be cut out of the runway surface but projected on top.
You can create all the lines and marking above the runway and use a shrinkwrap modifier in the Z 
direction to project the lines onto the runway surface. After you have finished the lines, make sure to 
apply all transformations. This is important later for the UV-mapping.

Note that all the signs, numbers and lines applied thanks to AsphaltPaint and GrassPaint are 
standardized as well as their position relative to the axis, center, or end of the runway.
This data is described in ICAO Annex 14 aerodromes. Book I. Book II is dedicated to heliports.
You will easily find a free version on the Internet.
Chapter 3 pages 99 to 122, Chapter 7 ages 211 to 214, for the 2018 version.
Here is a copy to illustrate the shape and the scaling, concerning numbers and letters 9 m high and 3 m 
wide except for the numbers 6 and 4.

Figure 28
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It is wise to create a library of all surface markings.
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The G file of an airport contains at least one of the surfaces that have just been listed. These surfaces do 
not cause any collision with gliders. They can also include frangible objects.
Similarly, the O file of an airport contains all the buildings that cause the destruction of the glider in the 
event of a collision. The G file is mandatory in Condor 3. Its absence results in a blue screen. A windsock 
with its mast constitutes the minimum of an O file. Buildings, hangars, etc. can be added to it. Assets 
(static gliders, car trailers, planes, 3D trees, etc.) common to most airports can be integrated into each 
airport with Condor 3.

Here is an example of the creation of the G file of Munster airport in Switzerland which corresponds to 
the preparatory work carried out previously.

Creating Plane Surfaces

Starting from planar square primitives and subdividing the edges and then moving the vertices. It is easy 
to build the different surface elements of the Airport in Top Orthographic. Save this file which may be 
useful to place and create the buildings.

Then import these surface elements, in a copy of the last Blender file, then move these surfaces along 
the Z axis. So that they are located above the patch (Figure 29)

Figure 29

Patch 

Grass 

AsphaltPaint 

Asphalt 
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You can also create its surfaces directly in a copy of the Blender file. Then you have to cut each surface 
as indicated previously and group the different surfaces in a collection.

Grass3D

Asphalt

Note: Asphalt paint
should not be cut out
of the runway

AsphaltPaint
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Sub-Surface texture

As in Condor 2, textures are applied automatically for Grass3D and Asphalt.
The difference in Condor 3 is that we have a new sub-texture that is applied to Grass3D and Asphalt to 
affect the colors and make them blend properly when approaching the airport from a distance.

The sub-texture is a dds file, extracted from the texture of the patch surrounding the airport, and Grass 
and Asphalt. You must use The Gimp or Photoshop.

It is best to extract this sub-texture from the patch containing the entire airfield, with a square shape to 
avoid distortions in the UV Map and simplify its alignment. The dimensions of this image must also be a 
multiple of 4 to be able to be saved correctly with an Alpha channel.

Before UVMapping make sure all transforms are applied (Object -> Apply -> All Transforms)

Figure 33

You must then perform the UV mapping of the Grass3D, Asphalt, GrassPaint, AsphaltPaint and 
AsphaltPaintYellow surfaces on this sub-texture. It is important that all these surfaces are mapped at the
same scale for the subtextures to show up correctly. Alternatively Asphalt and its paint can also be 
mapped to a muck texture. Here you can add skidmarks and colour variations in the asphalt:

In Blender with the last file where the surface textures are isolated, LMB on the UV tab.

In the left panel UV Editor load the sub-texture by:
Image > Open >

In the right 3D Viewport panel select in Object Mode Grass3D and Asphalt, then switch back to 
Edit Mode and check that you are still in Top Orthographic.

Proceed with the UV mapping by:
UV > Project from View
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The UV mapping appears in the UV Editor, horizontal panel and probably not at the right scale.

At First, in the UV Editor panel rotate from the negative value of the complement to -90° of the 
orientation angle of the airport calculated previously. In this case + 48.219°. Your UV Map is then 
perfectly oriented, and above all do not modify this orientation any more.

Now, in the UV editor panel with the S key for Scale and G to move, adjust the UV Map of the airport in 
the image. Use if necessary the zoom (mouse wheel) and the hand to move the view to perfect the  
location of the UV map (figure 34).

T
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hen, after saving your Blender file, you need to export the selected airport surfaces to Obj format with 
the following settings (figure 35):

•All selected airport surface objects 

• Include: Selection Only checked 

• Forward Axis : Y

             Up Axis : Z
• Triangulated Mesh checked .

Now open Object Editor Toolkit 2's and open the airport's Wavefront (.obj) file.
Usually the airport shape appears black (figure 36). This is usual, because the texture paths are not 
correctly identified and the RGB colors are all 0 .
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Start by copying your sub-texture into the correct directory of your scenery and any specialized textures 
you may have created for the tyre marks on the runway, frangible objects, etc. into a _muck file.

Then save your file in C3D with the correct name and in the Airport folder of your scenery.

Open this file again in C3d and make the necessary changes to the texture paths and the appropriate 
colors: for example 0.8 for Asphalt and 1 for AsphaltPaint. Where there is a peculiar texture the RGB 
colors should be set to 1. You can experiment with other values and even use the Alpha channel for 
transparencies (Figure 37).

At this point you get in Condor 3 tall 3D Grass (figure 38).

In Condor3 we have some realistic 3D grass. The length of this grass is controlled by the alpha channel in
the sub-texture. The white areas are long grass, and 50% of the grey areas are short grass. This DDS file 
should be saved in 8.8.8.8 ARGB format to prevent colored artifacts from appearing.

23



Condor V3 Airport Construction V 1.00

To get shorter grass, go back to The Gimp or Photoshop and select the Alpha channel and fill it with 
black with the paint bucket (figure 39).

Figure 39

In reality the sub-texture, here named Munster.dds, does not become red but greyed once saved (figure
40).

24



Condor V3 Airport Construction V 1.00

And in Condor 3 (figure41):

Figure 41

Of course you can experiment to achieve the desired effect. Also note that the color of the grass 
depends on the underlying color of the sub-texture (figure 42).

Figure 42

The new feature of Condor 3 is that it is possible to replace all the surface textures of each airport. Add 
your own version in the airport texture folder, linked to the G file in C3d and it will be used instead of 
the default texture.

Condor 2 Style Airports
Flattened airports from Condor 2 will work in Condor 3 without changes. But, if you want the 3D grass, 
then you must create and map the sub-texture as described above. To use AsphaltPaint, you must also 
have Asphalt. Similarly to use GrassPaint you must have Grass.
If the Asphalt runway is white, it is because the RGB colors are at 1 in the c3d file.
Replace for Asphalt color, 3 equal values for red, green and blue, between 0.5 and 0.8, and for 
AsphaltPaint 3 equal values between 0.8 and 1.
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